.it RDAP public test server

This experimental RDAP service is based on .it Registry public test environment registration data. The response data generated by this server are provided by .it Registry for experimental testing purposes only, and are not, and should not be considered to be, official WHOIS or RDAP query responses or data. This service allows the anonymous user to perform domain lookup and help queries as described in RFC 9082.

Table of contents

  1. Basic lookup queries
  2. HTTP HEAD method
  3. vCard Format Extensions
  4. Versioning Extension
  5. Redacted Extension
  6. JSContact Extension
  7. .it Response Extensions
  8. Contact Information

1. Basic lookup queries

2. HTTP HEAD method

The HEAD method can be used for the above queries.

3. vCard Format Extensions

This RDAP server implements the CC vCard parameter as described in RFC8605.

4. Versioning Extension

This RDAP server implements both the Versioning extension as described in draft-ietf-regext-rdap-versioning and the rdap-x media type as as described in draft-ietf-regext-rdap-x-media-type

5. Redacted Extension

This RDAP server implements the Redacted extension as described in RFC9537.

6. JSContact Extension

This RDAP server implements the JSContact format, a JSON contact representation alternative to vCard as described in RFC9553. Such a representation can be requested by adding to the query string the versioning parameter set to "jscontact-0.2". The JSContact format is allowed only for the endpoints: entity, domain, entities, domains. The extension version "jscontact-0.2" uses the JSContact version 2.0 as described in draft-ietf-calext-jscontact-uid. This JSContact version doesn't require the uid property.

Here in the following some examples:

The transition from jCard to JSContact is described in draft-ietf-regext-rdap-jscontact.

7. .it Response Extensions

This RDAP server provides extensions both to response fields and JSON values:

New Fields

New fields have been defined to map custom information of .it entities:

New Values

New values have been defined for the status field of a domain object in order to map custom statuses:

8. Contact Information

For any question or remark, please contact hostmaster@nic.it